Installation

Navigation:  MySQL Governor >

Installation

Previous pageReturn to chapter overviewNext page

IMPORTANT: Please make full database backup (including system tables) before you will do upgrade of MySQL or switch to MariaDB. This action will prevent data losing in case if something goes wrong.

 

To install MySQL governor on your server:

 

$ yum remove db-governor db-governor-mysql  # you can ignore errors if you don't have those packages installed
$ yum install governor-mysql
$ /usr/share/lve/dbgovernor/mysqlgovernor.py --install

 

If you are installing CloudLinux on a server running MariaDB already, do instead:

 

$ yum install governor-mysql 
$ /usr/share/lve/dbgovernor/db-select-mysql --mysql-version=mariadbXX
$ /usr/share/lve/dbgovernor/mysqlgovernor.py --install

 

* The installation currently supports only cPanel, Plesk, DirectAdmin, ISPmanager, InterWorx, Percona Server 5.6, as well as servers without control panel.

 

Installation for Percona Server 5.6 [requires MySQL Governor 1.1-22+ or 1.2-21+]:

 

$ /usr/share/lve/dbgovernor/mysqlgovernor.py --mysql-version=percona56

$ /usr/share/lve/dbgovernor/mysqlgovernor.py --install

 

** Please, note that MySQL/MariaDB will be updated from CloudLinux repositories.

 

*** MySQL Governor is compatible only with MySQL 5.x & MariaDB.

 

**** Please make sure to specify your MariaDB version instead of XX as follows:

55

MariaDB v5.5

100

MariaDB v10.0

101

MariaDB v10.1